re = /^[a-z0-9]+(?:[.\-_'+][a-z0-9]+)*@([a-z0-9]+(?:[-][a-z0-9]+)*\.)+[a-z]{2,}$/im
str = 'Valid emails:
user@domain.ru
na_me.lastname@subdomain.domain.ru
name-lastname@7.sub-sub-domain.subdomain.domain.ru
ni+ck\'name-name.lastname@d.oma-in-domain.ru
Invalid addresses in the user section:
.user@domain.ru
user.@domain.ru
-user@domain.ru
user-@domain.ru
us..er@domain.ru
us--er@domain.ru
Invalid addresses in the domain section:
user@-domain.ru
user@.subdomain.domain.ru
user@subdomain-.domain.ru
user@subdomain..domain.ru
user@domain.-domain.ru
user@dom--ain.ru'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end