#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{1,2}d\d{1,2}h\d{1,2}m\d{1,2}s"
Local $sString = "jihsdfj23jh453h4 1d12h30m10s jhsedfujht34uhji3g" & @CRLF & _
"" & @CRLF & _
"минусы эттой регулярки:" & @CRLF & _
"99d99h61m80s "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")