package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,2}d\d{1,2}h\d{1,2}m\d{1,2}s`)
var str = `jihsdfj23jh453h4 1d12h30m10s jhsedfujht34uhji3g
минусы эттой регулярки:
99d99h61m80s `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}