import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,2}d\\d{1,2}h\\d{1,2}m\\d{1,2}s";
final String string = "jihsdfj23jh453h4 1d12h30m10s jhsedfujht34uhji3g\n\n"
+ "минусы эттой регулярки:\n"
+ "99d99h61m80s ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}