re = /\d{1,2}d\d{1,2}h\d{1,2}m\d{1,2}s/m
str = 'jihsdfj23jh453h4 1d12h30m10s jhsedfujht34uhji3g
минусы эттой регулярки:
99d99h61m80s '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end