// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,2}d\d{1,2}h\d{1,2}m\d{1,2}s").unwrap();
let string = "jihsdfj23jh453h4 1d12h30m10s jhsedfujht34uhji3g
минусы эттой регулярки:
99d99h61m80s ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}