# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d(?=.\d))\./-/g;t' <<< ".a.b.1.2.
.a.b.1..2.
.a.b.1..2...1.1
.1.a..1..1.....1.1......1
-a-b-1.2-"