use strict;
my $str = '.a.b.1.2.
.a.b.1..2.
.a.b.1..2...1.1
.1.a..1..1.....1.1......1
-a-b-1.2-';
my $regex = qr/(?<!\d(?=.\d))\./p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";