const regex = /(?<!\d(?=.\d))\./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d(?=.\\d))\\.', 'g')
const str = `.a.b.1.2.
.a.b.1..2.
.a.b.1..2...1.1
.1.a..1..1.....1.1......1
-a-b-1.2-`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);