$re = '/(?<!\d(?=.\d))\./';
$str = '.a.b.1.2.
.a.b.1..2.
.a.b.1..2...1.1
.1.a..1..1.....1.1......1
-a-b-1.2-';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;