import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d(?=.\\d))\\.";
final String string = ".a.b.1.2.\n"
+ ".a.b.1..2.\n"
+ ".a.b.1..2...1.1\n"
+ ".1.a..1..1.....1.1......1\n\n"
+ "-a-b-1.2-";
final String subst = "-";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}