#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[Hh]ot\s?[sS]wap|.?HS?."
Local $sString = "hotswap" & @CRLF & _
"Hotswap" & @CRLF & _
"hot swap" & @CRLF & _
"Hot swap" & @CRLF & _
"Hot Swap" & @CRLF & _
"HS" & @CRLF & _
"HS>" & @CRLF & _
">HS>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")