$re = '/[Hh]ot\s?[sS]wap|.?HS?./m';
$str = 'hotswap
Hotswap
hot swap
Hot swap
Hot Swap
HS
HS>
>HS>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);