re = /[Hh]ot\s?[sS]wap|.?HS?./m
str = 'hotswap
Hotswap
hot swap
Hot swap
Hot Swap
HS
HS>
>HS>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end