#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?i)(?<=[a-z])'(?=[a-z])"
Local $sString = "Your Form xyz doesn't show the same child''s name as the name in your account with us."
Local $sSubst = "'||'''"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)