use strict;
my $str = 'Your Form xyz doesn\'t show the same child\'\'s name as the name in your account with us.';
my $regex = qr/(?i)(?<=[a-z])'(?=[a-z])/ip;
my $subst = '\'||\'\'\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";