re = /(?i)(?<=[a-z])'(?=[a-z])/i
str = 'Your Form xyz doesn\'t show the same child\'\'s name as the name in your account with us.'
subst = '\'||\'\'\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result