import Foundation
let pattern = #"(?i)(?<=[a-z])'(?=[a-z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Your Form xyz doesn't show the same child''s name as the name in your account with us."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'||'''"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)