using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<=[a-z])'(?=[a-z])";
string substitution = @"'||'''";
string input = @"Your Form xyz doesn't show the same child''s name as the name in your account with us.";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}