$re = '/(?i)(?<=[a-z])\'(?=[a-z])/i';
$str = 'Your Form xyz doesn\'t show the same child\'\'s name as the name in your account with us.';
$subst = "'||'''";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;