#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)url\(['"]?(?!(?:\w{3,4}:))([^\)'"]+?)['"]?\)"
Local $sString = "url(http://blah.jpg) " & @CRLF & _
"url(../images/blah.jpg) " & @CRLF & _
"url('../images/blah.png') " & @CRLF & _
"url(data:image/png,base64,xxxxxxx) " & @CRLF & _
"url("../images/blah.svg") " & @CRLF & _
"url("FTP://images/blah.svg") " & @CRLF & _
"URL('//images/blah')" & @CRLF & _
"url('ftpfolder/blah.jpg')" & @CRLF & _
"url(https://nice.com/yo.jpg) " & @CRLF & _
"url(ftps://nice.com/yo.jpg) " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")