using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url\(['""]?(?!(?:\w{3,4}:))([^\)'""]+?)['""]?\)";
string input = @"url(http://blah.jpg)
url(../images/blah.jpg)
url('../images/blah.png')
url(data:image/png,base64,xxxxxxx)
url(""../images/blah.svg"")
url(""FTP://images/blah.svg"")
URL('//images/blah')
url('ftpfolder/blah.jpg')
url(https://nice.com/yo.jpg)
url(ftps://nice.com/yo.jpg)
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}