import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url\\(['\"]?(?!(?:\\w{3,4}:))([^\\)'\"]+?)['\"]?\\)";
final String string = "url(http://blah.jpg) \n"
+ "url(../images/blah.jpg) \n"
+ "url('../images/blah.png') \n"
+ "url(data:image/png,base64,xxxxxxx) \n"
+ "url(\"../images/blah.svg\") \n"
+ "url(\"FTP://images/blah.svg\") \n"
+ "URL('//images/blah')\n"
+ "url('ftpfolder/blah.jpg')\n"
+ "url(https://nice.com/yo.jpg) \n"
+ "url(ftps://nice.com/yo.jpg) \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}