use strict;
my $str = 'url(http://blah.jpg)
url(../images/blah.jpg)
url(\'../images/blah.png\')
url(data:image/png,base64,xxxxxxx)
url("../images/blah.svg")
url("FTP://images/blah.svg")
URL(\'//images/blah\')
url(\'ftpfolder/blah.jpg\')
url(https://nice.com/yo.jpg)
url(ftps://nice.com/yo.jpg)
';
my $regex = qr/url\(['"]?(?!(?:\w{3,4}:))([^\)'"]+?)['"]?\)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}