re = /url\(['"]?(?!(?:\w{3,4}:))([^\)'"]+?)['"]?\)/i
str = 'url(http://blah.jpg)
url(../images/blah.jpg)
url(\'../images/blah.png\')
url(data:image/png,base64,xxxxxxx)
url("../images/blah.svg")
url("FTP://images/blah.svg")
URL(\'//images/blah\')
url(\'ftpfolder/blah.jpg\')
url(https://nice.com/yo.jpg)
url(ftps://nice.com/yo.jpg)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end