using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"clientField\(([a-zA-Z]+)\)(?:\[""?([\w]+)""?\]|(\.json\(\)))?";
string substitution = @"!!!!!";
string input = @"{
""name"": ""openid_connect"",
""label"": ""SSO"",
""args"": {
""name"": ""openid_connect"",
""scope"": [
""Gitalab""
],
""response_type"": ""code"",
""client_auth_method"": ""query"",
""discovery"": true,
""client_id"": ""clientField(clientId)"",
""client_secret"": ""clientField(secret)"",
""client_auth_method"": ""query"",
""redirect_uri"": clientField(redirectUris).json(),
""redirect_uri"": clientField(redirectUris)[0],
""redirect_uri"": clientField(redirectUris)[""test""],
""client_auth_method"": ""query""
}
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}