re = /clientField\(([a-zA-Z]+)\)(?:\["?([\w]+)"?\]|(\.json\(\)))?/m
str = '{
"name": "openid_connect",
"label": "SSO",
"args": {
"name": "openid_connect",
"scope": [
"Gitalab"
],
"response_type": "code",
"client_auth_method": "query",
"discovery": true,
"client_id": "clientField(clientId)",
"client_secret": "clientField(secret)",
"client_auth_method": "query",
"redirect_uri": clientField(redirectUris).json(),
"redirect_uri": clientField(redirectUris)[0],
"redirect_uri": clientField(redirectUris)["test"],
"client_auth_method": "query"
}
}'
subst = '!!!!!'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result