import Foundation
let pattern = #"clientField\(([a-zA-Z]+)\)(?:\["?([\w]+)"?\]|(\.json\(\)))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"name": "openid_connect",
"label": "SSO",
"args": {
"name": "openid_connect",
"scope": [
"Gitalab"
],
"response_type": "code",
"client_auth_method": "query",
"discovery": true,
"client_id": "clientField(clientId)",
"client_secret": "clientField(secret)",
"client_auth_method": "query",
"redirect_uri": clientField(redirectUris).json(),
"redirect_uri": clientField(redirectUris)[0],
"redirect_uri": clientField(redirectUris)["test"],
"client_auth_method": "query"
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"!!!!!"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)