// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)clientField\(([a-zA-Z]+)\)(?:\["?([\w]+)"?\]|(\.json\(\)))?"#).unwrap();
let string = "{
\"name\": \"openid_connect\",
\"label\": \"SSO\",
\"args\": {
\"name\": \"openid_connect\",
\"scope\": [
\"Gitalab\"
],
\"response_type\": \"code\",
\"client_auth_method\": \"query\",
\"discovery\": true,
\"client_id\": \"clientField(clientId)\",
\"client_secret\": \"clientField(secret)\",
\"client_auth_method\": \"query\",
\"redirect_uri\": clientField(redirectUris).json(),
\"redirect_uri\": clientField(redirectUris)[0],
\"redirect_uri\": clientField(redirectUris)[\"test\"],
\"client_auth_method\": \"query\"
}
}";
let substitution = "!!!!!";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}