use strict;
my $str = '{
"name": "openid_connect",
"label": "SSO",
"args": {
"name": "openid_connect",
"scope": [
"Gitalab"
],
"response_type": "code",
"client_auth_method": "query",
"discovery": true,
"client_id": "clientField(clientId)",
"client_secret": "clientField(secret)",
"client_auth_method": "query",
"redirect_uri": clientField(redirectUris).json(),
"redirect_uri": clientField(redirectUris)[0],
"redirect_uri": clientField(redirectUris)["test"],
"client_auth_method": "query"
}
}';
my $regex = qr/clientField\(([a-zA-Z]+)\)(?:\["?([\w]+)"?\]|(\.json\(\)))?/mp;
my $subst = '!!!!!';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";