package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)clientField\(([a-zA-Z]+)\)(?:\["?([\w]+)"?\]|(\.json\(\)))?`)
var str = `{
"name": "openid_connect",
"label": "SSO",
"args": {
"name": "openid_connect",
"scope": [
"Gitalab"
],
"response_type": "code",
"client_auth_method": "query",
"discovery": true,
"client_id": "clientField(clientId)",
"client_secret": "clientField(secret)",
"client_auth_method": "query",
"redirect_uri": clientField(redirectUris).json(),
"redirect_uri": clientField(redirectUris)[0],
"redirect_uri": clientField(redirectUris)["test"],
"client_auth_method": "query"
}
}`
var substitution = "!!!!!"
fmt.Println(re.ReplaceAllString(str, substitution))
}