#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z](?!.*--)(?!.*\.(?:[^.]{0,2}$|[.\d-]))[a-z.\d-]{1,14}[a-z\d]$"
Local $sString = "abcd123" & @CRLF & _
"abc.defg" & @CRLF & _
"mnop-1234" & @CRLF & _
"mnop--1234" & @CRLF & _
".abcdefg" & @CRLF & _
"1234pqrs" & @CRLF & _
"xyz123-" & @CRLF & _
"-abcdefg" & @CRLF & _
"abcd.ef" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")