import Foundation
let pattern = #"^[a-z](?!.*--)(?!.*\.(?:[^.]{0,2}$|[.\d-]))[a-z.\d-]{1,14}[a-z\d]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcd123
abc.defg
mnop-1234
mnop--1234
.abcdefg
1234pqrs
xyz123-
-abcdefg
abcd.ef
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)