$re = '~^[a-z](?!.*--)(?!.*\.(?:[^.]{0,2}$|[.\d-]))[a-z.\d-]{1,14}[a-z\d]$~m';
$str = 'abcd123
abc.defg
mnop-1234
mnop--1234
.abcdefg
1234pqrs
xyz123-
-abcdefg
abcd.ef
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);