re = /^[a-z](?!.*--)(?!.*\.(?:[^.]{0,2}$|[.\d-]))[a-z.\d-]{1,14}[a-z\d]$/m
str = 'abcd123
abc.defg
mnop-1234
mnop--1234
.abcdefg
1234pqrs
xyz123-
-abcdefg
abcd.ef
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end