using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z](?!.*--)(?!.*\.(?:[^.]{0,2}$|[.\d-]))[a-z.\d-]{1,14}[a-z\d]$";
string input = @"abcd123
abc.defg
mnop-1234
mnop--1234
.abcdefg
1234pqrs
xyz123-
-abcdefg
abcd.ef
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}