import re
regex = re.compile(r"^[a-z](?!.*--)(?!.*\.(?:[^.]{0,2}$|[.\d-]))[a-z.\d-]{1,14}[a-z\d]$", flags=re.MULTILINE)
test_str = ("abcd123\n"
"abc.defg\n"
"mnop-1234\n"
"mnop--1234\n"
".abcdefg\n"
"1234pqrs\n"
"xyz123-\n"
"-abcdefg\n"
"abcd.ef\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")