# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"[^"]*"|(\w{4,})(?!\w|\*)/$1*/gm;t' <<< "Cats in two stylish* hats
Cats in \"some very* stylish\" hats
Cats
"