use strict;
my $str = 'Cats in two stylish* hats
Cats in "some very* stylish" hats
Cats
';
my $regex = qr/"[^"]*"|(\w{4,})(?!\w|\*)/mp;
my $subst = '$1*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";