using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]*""|(\w{4,})(?!\w|\*)";
string substitution = @"$1*";
string input = @"Cats in two stylish* hats
Cats in ""some very* stylish"" hats
Cats
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}