$re = '/"[^"]*"|(\w{4,})(?!\w|\*)/m';
$str = 'Cats in two stylish* hats
Cats in "some very* stylish" hats
Cats
';
$subst = "$1*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;