re = /"[^"]*"|(\w{4,})(?!\w|\*)/m
str = 'Cats in two stylish* hats
Cats in "some very* stylish" hats
Cats
'
subst = '$1*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result