const regex = /"[^"]*"|(\w{4,})(?!\w|\*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^"]*"|(\\w{4,})(?!\\w|\\*)', 'gm')
const str = `Cats in two stylish* hats
Cats in "some very* stylish" hats
Cats
`;
const subst = `$1*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);