const regex = /^([^-]*) - (.*)$/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^-]*) - (.*)$', 'gi')
const str = `I'm a link - http://google.com`;
const subst = `<a href="$2"">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);