import Foundation
let pattern = #"^([^-]*) - (.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"I'm a link - http://google.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="$2"">$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)