$re = '/^([^-]*) - (.*)$/i';
$str = 'I\'m a link - http://google.com';
$subst = "<a href=\"$2\"\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;