import re
regex = re.compile(r"^([^-]*) - (.*)$", flags=re.IGNORECASE)
test_str = "I'm a link - http://google.com"
subst = "<a href=\"$2\"\">$1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)