re = /^([^-]*) - (.*)$/i
str = 'I\'m a link - http://google.com'
subst = '<a href="$2"">$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result