use strict;
my $str = 'I\'m a link - http://google.com';
my $regex = qr/^([^-]*) - (.*)$/ip;
my $subst = '<a href="$2"">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";