#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@require (.+?)?(?:-->|\s)"
Local $sString = "<head>" & @CRLF & _
" <meta charset="UTF-8">" & @CRLF & _
" <title></title>" & @CRLF & _
" <!--@require a.css-->" & @CRLF & _
" <!--@require BOWER/jquery-->" & @CRLF & _
" <!--@require /build/bundle-->" & @CRLF & _
" <!--" & @CRLF & _
" @require bootstrap" & @CRLF & _
" @require bootstrap.css" & @CRLF & _
" @require bootstrap.font" & @CRLF & _
" -->" & @CRLF & _
"</head>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")